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1.0 Installation

To connect the Configurator to the Fire Alarm Control Panel you must:

� Install the Configurator.

� Insert the Wibu key.

� Connect the cable.

� Start the Configurator.

Follow the instructions below to complete these steps.

1.1 Install the Configurator

You need the following items in order to install the Configurator:

� Windows 7 or Windows 10 laptop computer with a USB port.

� MGC-400 Series Configuration Utility (the Configurator).

Follow these instructions to install the Configurator.

1. Right-click the MGC-400_Configurator icon, and then click Run as Administrator.

The Setup program starts.

Figure 1 Setup - MGC-400 Configurator
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2. Click I accept the agreement to accept the agreement, and then click Next.

The Select Destination Location window appears.

Figure 2 Select Destination Location

3. Click Browse and select a location for the Configurator to be installed, and then click 

Next.

The Select Start Menu Folder window appears.

Figure 3 Select Start Menu Folder
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4. Click Next.

The Ready to Install window appears.

Figure 4 Ready to Install

5. Click Install.

The MGC-400 Configurator software is installed.

6. The FTDI CDM Drivers window appears. These drivers are necessary for connecting to 

the panel with a USB cable.

Figure 5 FTDI CDM Drivers
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7. Click Extract.

The Welcome window appears.

Figure 6 Welcome to the Device Drive Installation Wizard

8. Click Next.

The License Agreement window appears.

Figure 7 Device Drive License Agreement
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9. Click I accept the agreement to accept the agreement, and then click Next.

The Completing the Device Driver Installation Wizard window appears.

Figure 8 Completing the Device Drive Installation Wizard

10. Click Finish.

The WibuKey Setup window appears. The Wibu key is a USB flash drive that provides 

security by controlling access to the Fire Alarm Control Panel.

Figure 9 WibuKey Setup
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11. Click Next.

The language selection window appears.

Figure 10 WibuKey Language Selection

12. Click Next.

The destination folder window appears.

Figure 11 WibuKey Destination Folder

13. Click Next.

14. On the next window, click Yes to create the folder.

Figure 12 The specified folder does not exist
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The components window appears.

Figure 13 WibuKey Components

15. Click Next.

The summary window appears.

Figure 14 WibuKey Summary



17

16. Click Next.

The second summary window appears.

Figure 15 WibuKey Second Summary

17. Click Next.

The Finish window appears.

Figure 16 WibuKey Finish

18. Click Finish.

19. Click OK on the WibuKey driver successfully installed window.

Figure 17 WibuKey driver successfully installed
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After the WibuKey drivers have been installed, the last screen of the MGC-400 Setup 

Wizard appears.

Figure 18 Completing the MGC-400 Configurator Setup Wizard

20. Click Finish.

21. Close the Welcome to the WibuKey User Help window.

Figure 19 Welcome to the WibuKey User Help
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1.2 Insert the Wibu key

1. Insert your Wibu key into the computer.

If a Security Key Logon window appears that says that your security key is an older 

version, you must contact your ESD Administrator or Mircom technical support to 

upgrade your key. Otherwise, you might not be able to connect to the FX-400/401.

1.3 Connect the Computer to the Panel through the Micro-B USB 

Port on the Core Board

You need:

� USB A plug to micro-B plug cable.

Figure 20 The core board

Figure 21 USB micro-B connector

Figure 22 USB A to micro-B plug cable to P5 on core board

JW4 JW5

Core Board

Micro-B USB Port

Computer FACPUSB A to micro-B Cable
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1. Connect the USB cable to a USB port on the computer, and to the USB port on the FX-

400/401 plug-in core board. This port is labeled P5.

2. Go to section 1.4.

1.4 Start the Configurator

1. Start the Configurator, then click File, then click User Preferences.

2. Enter your name in the User Name field.

3. In the Serial Port menu, select the COM port that the cable is using.

Figure 23 Select the COM port in User Preferences

4. Click OK to close the User Preferences window.

5. Click Panel, then click Connect.

The Connection window appears.

Figure 24 Connection
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6. Click Connect.

After a connection has been established a window might appear saying that the panel 

time and the PC time do not match.

7. Click Yes.

The Update Panel Time window appears.

8. Set the time and click OK.

A window appears saying that the time has been updated.

9. Click OK.
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2.0 User Preferences

The first time the Configurator starts, the User Preferences window appears.

Figure 25 User Preferences window

Table 1 User Preferences

Name Description

User Name Used for the author of all new jobs and job versions.

Serial Port Designates which COM port (or USB virtual COM port) 

the Configurator uses to connect to the panel.

Security Key Lists the ports where a Wibu key can be inserted. The 

Wibu key is required.

BDM Port Designates which parallel port the Background 

Debugging Module uses (for those products that support 

this interface).

Database Folder Specifies where the main Configurator.mdb database file 

resides. Usually the folder where the Configurator is 

installed.

Job Edit Folder Specifies where individual job files are extracted to and 

imported from.

Job Build Folder Specifies where the 'C' file output files are written by Job 

Validate and other trace or debug facilities.

Backup Folder Specifies where backup database files are written to and 

restored from.

Show Tools Menu Displays or hides an additional Tools menu. This menu 

contains trace and debug facilities and some features that 

Technical Support may require a user to turn on to gather 

diagnostic information.

Keep Only Latest Versions 

After Backup

If enabled, only the latest versions of all jobs are kept after 

a successful Backup Database command. All older 

versions are removed from the current database.
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3.0 Configurator and Firmware 
Compatibility

 Follow these instructions to verify that you are using the correct configurator and firmware 

versions.

1. In the configurator window, navigate to the Help menu located in the top row.

Figure 26 Help

2. Click on About MGC-400 Series Configurator Utility.

A new window will appear, displaying details of the current configurator and database 

versions, and the recommended and minimum firmware versions.

Figure 27 About MGC-400 Series Configurator Utility

3. Click on Firmware Compatibility.

A table will appear in the window, providing information on the compatibility between the 

configurator and firmware versions.

Figure 28 Firmware Compatibility
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4.0 Overview

In order to operate as a fire alarm, a fire alarm panel must be loaded with firmware and 

configuration data. A set of configuration data, used to uniquely describe and control a given 

set of hardware, is called a Job. The Configurator allows you to create and manage jobs. It 

also allows you to send firmware to a panel and all its related CPUs.

The Configurator typically runs on a portable computer that the technician takes to the job site 

connects to the panel. The technician uses the Configurator to prepare a job, and then send 

the job to the panel. The same or a different authorised technician can later retrieve the job 

from the panel, modify it and send it back.

The job repository is a relational database. Jobs can be imported or merged from another 

database, copied, deleted, and archived in various formats. A job can be printed, or two 

versions of a job can be compared.

The first time the Configurator is opened, it prompts you for the paths and file names where 

jobs, backups, and the database should be stored.

4.1 Configurator Window

The Configurator window is divided into three panes.

Figure 29 MGC-400 Configurator

4.1.1 Job Tree

On the left of the screen, the job is represented as a tree, similar to a file explorer. At the 

highest level in the tree are the CPUs. Under each CPU are its components - annunciators, 

loop controllers, and so on. Some items are further subdivided; for example, an annunciator is 

divided into display adders and a loop controller into loops.

Some items in the tree do not directly represent a physical component. For example, tree 

nodes exist for input and output summaries and for common controls.

4.1.2 Details

The top right pane is used to display the details of the currently selected tree node.

JOB TREE

DETAILS

CORRELATIONS
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4.1.3 Correlations

Programming a Fire Alarm Control Panel consists of correlating inputs to outputs. For 

example, you might correlate all the smoke detectors on the first floor to the speakers on the 

first and second floors, and smoke detectors on the second floor to the speakers on the first, 

second, and third floors, and so on.

The third, bottom right pane is used to show correlations from an item selected in the top right 

pane. When a loop is selected in the tree, the top right pane shows all of its devices or circuits. 

When a input circuit is selected in the list, then the bottom pane shows the output circuits it is 

correlated to.

A tool bar provides convenient short cuts to the more frequently used functions.
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5.0 Menus

5.1 File Menu

The File Menu contains the following commands:

5.2 Job Menu

The Job Menu contains the following commands:

Table 2 File Menu

Name Shortcut Description

Backup 

Database

Makes a copy of the Master Database in the file folder 

specified in the User Preferences. The backup file has a 

name of the form YYYY-MM-DD.mdb. The Restore 

Database command recovers all of the jobs in the backed 

up database. The Import Job command recovers selected 

jobs from the backed up database. Back up your Master 

Database often and store the backup file on removable 

media.

Restore 

Database

Restores the backup database to the active database 

directory for use or modification. This command 

overwrites the existing database and returns the 

database to the date the backup was made.

Compact 

Database

To ensure optimal performance, you should compact and 

repair your database on a regular basis. If you have purged 

job versions or deleted jobs, compacting the database 

regains the space occupied by those records.

User 

Preferences

Specifies user preferences, such as the location of 

database, backups and job files.

Print

Ctrl+P

Prints the active job.

Print Preview Displays a Print Preview of the active job.

Print Setup Selects the printer, paper size and orientation for a print job.

Exit Closes the Configurator.

Table 3 Job Menu

Name Shortcut Description

New Job

Ctrl+N

Opens the Create Job window which lets you start a new 

job. The new job can be based on a supplied template or on 

an existing job.
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5.3 Insert Menu

The Insert Menu contains the following commands.

Some commands may be disabled (greyed) depending on what items are selected.

Open Job

Ctrl+O

Opens an existing job from your database.

Import Job Imports a selected job version from an external database or 

serialized job archive and converts the job to the current 

version if necessary.

Export Job
Ctrl+E

Exports the current job in one of two formats: a single job 

database file, or a compact, serialized archive format.

Import Tags Imports a CSV file and uses it for the tags in the job.

Export Tags Exports the tags as a CSV (comma separated values) file 

that you can open in a spreadsheet editor.

New Version

Ctrl+W

Makes a copy of the current job, assigning it the next 

highest version number. You are prompted for mandatory 

comments and may also override the Author field. The Job 

Name cannot be changed. The new version is unlocked for 

editing.

Delete Job 

Version
Ctrl+D

Permanently deletes the current job version from the 

database.

Version 

History

Displays the version history (date, author, comments) for the 

current job.

Compare Job 

Versions

Compares two versions of the same job, or two similar jobs 

of different lineage.

Validate Job Performs all of the steps normally performed when the 

Configurator prepares to send a job to the panel.

Edit Job Toggles the lock on a job that is protected against 

unintentional edits or has been down loaded to a panel.

Table 4 Insert Menu

Name Description

Add Loop Controllers Adds an Addressable Loop Controller to the job (FX-401 only).

Add Annunciator Adds an LCD or LED Annunciator to the job.

Add Display Adder Adds a Display Adder to an Annunciator or Base Panel.

Add Device If the selected tree item is a device loop, launches a dialog to 

add a device.

Add Group If the selected tree item is Bypass Groups, adds a new bypass 

group to the Bypass Group view.

Table 3 Job Menu (Continued)

Name Shortcut Description
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5.4 Edit Menu

The Edit Menu contains the following commands.

Some commands may be disabled (greyed) depending on what items are selected.

5.5 Panel Menu

The Panel Menu contains the following commands:

Add Correlations Launches a dialog that allows correlations to be added to the 

selected devices or display items.

Table 5 Edit Menu

Name Short cut Description

Delete Item Del Deletes the currently selected item.

Modify Item
Ctrl+M

If the currently selected item is a row in an editable list, then 

the first changeable cell is selected and prepared for editing.

Copy

Ctrl+C

Copies the selected item(s) to the clipboard.

Paste

Ctrl+V

Pastes items from the clipboard to the selected destination.

Paste Special

Ctrl+Shift

+V

Similar to Paste. Opens the Paste Special dialog to allow 

defaults to be changed before pasting.

Table 6 Panel Menu

Name Short cut Description

Connect

Ctrl+L

Establishes a connection between the configuration tool and 

the panel, enabling most of the other commands in this 

menu. Remember to disconnect when you are finished, as a 

trouble appears on the fire alarm panel as long as the laptop 

is connected.

Send Job Ctrl+S Sends the job to the panel.

Get Job

Ctrl+G

Gets the job from the panel and stores it on the 

configuration tool's database. The job becomes the current 

job.

Panel 

Information

Displays detailed information about the panel to which the 

configuration tool is connected.

Table 4 Insert Menu (Continued)

Name Description
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5.6 Tools Menu

The items under the Tools Menu are used mainly for troubleshooting and diagnostic purposes 

by the factory.

Security Key 

Info

Displays a window with the security key information such as 

serial number, expiry date, and number of uses.

Event Log Displays a list of events from the panel.

Modify Mode Ctrl+U Modifies the panel directly.

Quick Update In modify mode, tags, correlations and options can be 

modified instantly without having to send the job.

Upgrade 

Firmware

Opens a wizard which guides you through the firmware 

upgrade process.

Table 7 Tools Menus

Name Short cut Description

Extract All Db Extracts the latest version of every job to individual database 

files.

Validate All Ctrl+S Validates the latest version of every job on the database.

Build Job
Ctrl+B

Builds the job, assuming the latest product version, creating 

a "c" file in the Job Build folder.

Build Job (old 

versions)...
Builds the job "c" file for a specified, older product version.

Link Statistics Displays the connection link statistics.

Log Send Toggles the current state of the "dump on send" option. 

Causes the "c" file to be produced and dumped on a Get 

Job.

Log Get Toggles the current state of the "dump on get" option. 

Causes the "c" file to be produced and dumped on a Send 

Get.

Log Comms Toggles logging of serial communications.

Trace Toggles the current state of the trace option. When turned 

on this causes debug information to be written to a trace file.

Display 

Structure
Lets you view and log panel data structures.

External Bus Toggles the "Use External Bus" setting. When turned on, this 

signals that the Configurator is connected to the external 

bus of the panel.

Note: The Tools menu is only available if you checked the Show Tools Menu option. 

See section 2.

Table 6 Panel Menu (Continued)

Name Short cut Description

i
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5.7 Quick Bar

5.8 Ctrl + A

Pressing Ctrl + A will select all devices in a list. This applies to any list or component selection 

within the configurator, eliminating the need to manually select items.

5.9 Undo/ Redo

The Undo (Ctrl + Z) and Redo (Ctrl + Y) function applies to all operations that update the 

database file, such as adding or deleting devices, address changes, or loop modifications. 

Rapid actions performed within one second are treated as a single operation. Column 

adjustments and similar changes cannot be undone. Each Undo can be Redone, with a 

maximum of 10 steps.

Table 8 Quick Bar Icons

Name

New Job

Select Job and 

Version

Toggle Edit Job

Copy

Paste 

Paste Special

Delete

Print

Compare Jobs

Connect

Send Job

Get Job

Panel Info

Security Key

About

Help On
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6.0 Job Tree and Details Pane

This section covers the following components of the Configurator:

� Job Details

� Details Pane

� Bypass Groups

� Output Zone

� Main Display

� Display Adder

� Dialer

� Common System Status

� Input Summary and Output Summary

6.1 Job Details

Figure 30 Job Details

6.1.1 Job Info

This section shows details of the job's name, number, creation date and author. The multi-line 

comments field can be edited and will become part of the job's version history.

6.1.2 Language

This section specifies the language used to display system messages on the front LCD display 

and on any LCD annunciator. User defined tags and messages are not affected.
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6.1.3 Options

Table 9 Job Options

Name Description

Manual Signal Silence Check this option to enable the panel's Signal Silence 

switch.

Fire Drill Check this option to enable the panel's Fire Drill switch.

Waterflow Retard Operation Check this option to perform a retard operation for 

initiating circuits configured as waterflow. If this option is 

unchecked, all the initiating circuits configured as 

waterflow act as non-verified alarms.

Auxiliary Disconnect Alarm 

and Supervision

Check this option to make the auxiliary disconnect 

operation disconnect alarm and supervisory relays. If this 

option is unchecked, the auxiliary disconnect operation 

has no effect on the alarm and supervisory relays.

Alarm Transmit Silence Check this option to cause the Alarm Transmit and 

Auxiliary Alarm Relay to reset on Signal Silence rather 

than on the Reset switch.

Subsequent Alarm Per Zone Check this option to enable Subsequent Alarm per Zone. 

See section 6.10.

Common Supervisory Relay Check this option to make the common supervisory relay 

act as a common alarm relay.

Signal Isolator Used Check this option if isolators are present on the loop 0 

powered output circuits.

Two Stage Operation Check this option to configure the system as two stage. If 

this option is unchecked, the system is single stage (FX-

401 only).

Second Stage Alarm Relay 

Operation

Check this option to use the common alarm relay for 

second stage only of a two stage system. If this option is 

unchecked, the common alarm relay is used for both 

stages (FX-401 only).

Positive Alarm Sequence Check this option to enable the Positive Alarm Sequence 

feature. It only applies to alarm input devices with the PA 

flag (F2) set. This feature cannot be enabled if Two Stage 

Operation is enabled.

CO Takes Priority When disabled, the fire alarm signals take priority over the 

CO alarm signals. This means that if a fire alarm is active, 

the indicating circuits sound at the temporal 3 rate even if 

there is a CO alarm at the same time.

When enabled, the CO alarm signals take priority over the 

fire alarm signals. This means that if a CO alarm is active, 

the indicating circuits sound at the temporal 4 rate even if 

there is a fire alarm at the same time.

Building Alert Check this option to cause the panel to produce alert 

sounds on building (monitor) in/out activation.

Polled Device Flashes Check this option to cause device LEDs to flash when 

polled.
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Class-A Loop Check this option if the addressable loop on the base 

panel operates in class A mode.

Disable Auto Test Check this option to enable the NFPA device periodical 

self-test.

AR/Buzzer Silence Check this option to change the Buzzer Silence button on 

the panel to Auxiliary Reset.

If this option is enabled you can silence the buzzer by 

pressing these buttons:

� Any of the queue buttons

� Alarm Acknowledge

� Visual Indicator Test

CO expiry as supervisory When enabled, a CO expiry is reported to the receiving 

station as a CO Cell expiry or supervisory message.

When disabled, a CO expiry is reported to the receiving 

station as a trouble condition.

Strobes Type Specify the Strobe Type that should be used on the panel.

� Gentex

� System Sensor

� Mircom

� Wheelock

Evacuation Code Specify the Evacuation Code that should be used on the 

panel.

� Continuous

� March Time

� Temporal

� California

Agency Selection Specify the Agency Standard that should be used on the 

panel.

� ULI Standard

� ULC Standard

Table 9 Job Options (Continued)

Name Description
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6.1.4 Timers

Table 10 Timers

Timer Type Possible Settings

Signal Silence Inhibit Use this function to inhibit the Signal Silence button for a 

desired length of time. The time period should expire before 

the signals may be silenced.

Disabled, 10, 20, 30 seconds, 1 minute.

Auto Signal Silence Use this function to set the time period for which the 

indicating circuits sound before they are automatically 

silenced. This timer cannot be set shorter than then 

General Alarm or Signal Silence Inhibit timers.

Disabled, 5, 10, 15, 20, 30 minutes.

New Alarm (Secs) This feature is not used in UL applications.

This feature is used to satisfy the requirements of Division 

B, Part 3.2.4.18 of the National Building Code of Canada 

2015, and the Ontario Building Code 2016 section 

3.2.4.20(13), with respect to automatic suite silence. 

Signals that are correlated to the New Alarm Active 

Common System Status go active for the indicated amount 

of time and then go silent. The alarm continues to play on 

the outputs correlated with the zone or input that started the 

alarm.

10, 20, 30, 40, 50, 60, 70, 80, 90, 100, 110, 120 seconds.

General Alarm On a two stage system, the stage one alarm (alert) will 

change to the stage two alarm (general alarm) after this 

amount of time. This timer must be shorter than the Auto 

Signal Silence timer. This timer is disabled unless Two 

Stage Operation is selected.

Disabled, 5, 10, 20, 30 minutes.

Power Fail Delay This feature allows a programmed delay before the AC fail 

trouble is transmitted by the optional PR-300.

0, 1, 2, 3 hours.

Auto Resound (Mins) This feature is not used in UL applications.

This feature is used to satisfy the requirements of Division 

B, Part 3.2.4.18 of the National Building Code of Canada 

2015, and the Ontario Building Code 2016 section 

3.2.4.20(13), with respect to automatic suite silence. This 

timer starts when the New Alarm timer expires. It specifies 

the time after which the signals that are correlated to the 

Auto Suite Resound Common System Status will activate 

again if the alarm remains unacknowledged.

5, 6, 7, 8, 9, 10, 11, 12 minutes.
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6.1.5 Date and Time

6.1.6 Holidays

This dialog allows you to add and remove holiday definitions for use when a panel is 

configured by checking the Enable Auto After Hours option.

Figure 31 Holidays Window

Table 11 Date and Time

Name Description

Enable Daylight Savings Check this box to enable automatic change to and from 

daylight saving time.

Clock Daily Compensation Specify the number of seconds (signed) to be applied daily 

to the panel clock.

Enable Auto After Hours Check this box to enable After Hours operation. If After 

Hours operation is enabled, then you can change the 

detector sensitivity for the times designated as After Hours 

(the Sens B column; see section 6.2).

Use the following controls to configure after hours 

settings. Holidays, nighttime, and weekends are 

considered after hours.

Holidays - Modify Compose a new holiday definition in the YYYY MM DD 

edit boxes and press Add holiday. You can specify 

recurring holiday by using wild cards. For further 

instructions on adding and deleting holidays see section 

6.1.6.

Daytime Start and End 

Hours
Specify when daytime begins and ends.

Weekend Start and End 

Hours
Specify when the weekend begins and ends.
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To add a new holiday

1. Compose a new holiday definition in the YYYY MM DD edit boxes.

2. If the holiday lasts longer then one day change the value in the Duration edit box to the 

desired length.

3. Click Add Holiday.

The holiday appears in the Holidays defined list.

To specify recurring holidays

Recurring holidays can be specified by using wild cards.

For a holiday that happens once a year enter 9999 in the YYYY edit box.

� For example, 9999 01 01 for New Years Day.

Enter 99 for a month or day to specify a recurring holiday.

� For example, 9999 99 01 to specify that the first of every month is a holiday.

� For example, 9999 07 99 to specify that the plant is shut down for the whole of July for 

summer vacations.

As holidays are added or removed, the list on the "parent" form is maintained to be in 

agreement. An error message is displayed if the limit for the total number of holidays would be 

exceeded.

To remove a holiday

1. Select the desired date from the Holidays defined list and press Delete Selected 

Holiday.

2. Press Close to return to the Job Details form.

6.1.7 Port Settings

6.2 Details Pane

The details pane display the hard wired circuits in loop 0 and the addressable devices in loop 

1 (and loops 2 and 3 on the FX-401). Table 13 shows the information available in the details 

pane. In general, the columns are the same for both hardwired and addressable loops.Some 

columns containing advanced information are normally hidden. They are listed as Visible: No 

in Table 13.

Note: The program prevents you from entering duplicate holidays, but does not check 

for "nested" holidays.

Table 12 Port Settings

Name Description

Port Protocol None, Printer, OpenGN

Port Baud Rate 2400, 4800, 9600, 19200

i
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To show a hidden column, move the cursor between the column headings until it turns into a 

vertical line with two horizontal arrows, like this: 

Then click and drag the edge of the column to the left.

Table 13 Loop Details

Column Visible Description

Addr
Yes

MIX-4000 series device addresses are in the form n.n. See 

section 7.4.2.

Lp No Loop Number.

Ckt No
No

An internal, sequentially assigned number. One set for inputs, 

another for outputs.

Device
Yes

Conventional: fixed hardware loop circuits.

Addressable: chosen when adding the device.

Options Yes The options depend on the type of device.

Type
Yes

The process type of the device. The list of types depends on the 

device.

F1
Yes

NS: Non Silenceable - used on inputs and supervised outputs.

NB: Non Bypassable - used on relays.

F2

No

GA: Second Stage Alarm - used in a two stage system.

PA: Positive Alarm - the positive alarm sequence applies to 

inputs with this flag.

F3

Yes

AR: Auxiliary Reset required - used on relays. A relay with the 

AR flag will be latched after activation and will stay latched after 

system reset. To clear the activation, press the Auxiliary Reset 

switch (see "AR/Buzzer Silence" on page 33).

CA: Class A wiring - used on Dual Input Modules and Dual Input 

Mini Modules. It indicates that the wiring of this device is Class 

A.

F4 Yes NF: No flash - the LED will not flash during normal polling.

Sens

Yes

The sensitivity of various sensors. Displays the percentage 

equivalents of internal absolute values. Takes into account 

jurisdiction (ULI vs. ULC).

The number represents the amount of smoke that will trigger an 

alarm. A lower number means the sensor will be more sensitive.

Sens B

No

The after hours and night time sensitivity of sensors in a system 

configured to have after hours operation.

The number represents the amount of smoke that will trigger an 

alarm. A lower number means the sensor will be more sensitive.

Tag (Line1 

and 2)
Yes

The text of the tag, in two 20 character fields, representing the 

lines displayed on the front panel when an event occurs.

Delay
Yes

The time in seconds for delaying the activation of output 

devices.
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6.2.1 Change Device Information in the Loop Details

1. Double-click in the column of the option you want to change (Figure 32).

2. Enter the new value or select it from the menu that appears.

Figure 32 Double-click in the loop details to change device information

6.3 Bypass Groups

Add devices to a bypass group if you want to bypass the devices simultaneously. See section 

7.7 for instructions on configuring a display adder to operate a bypass group.

6.4 Output Zone

An output zone contains addressable output devices that you want to activate simultaneously.

There are three types of addressable output devices:

� Sounder base

� Relay base

� Relay modules and supervised output modules

There are several requirements for output zones:

� An output zone must be correlated to devices of the same type. For example, an output 

zone should not be correlated to a mix of sounder bases and relay bases.

� All devices in an output zone must be on the same loop.

� Output devices that are correlated to an output zone cannot be correlated to anything 

else.

� An output zone must be correlated to an input or system status.

Note: Not all the options are editable. The editable options depend on the type of 

device.

Table 14 Bypass Groups

Name Description

No. Number of the bypass group.

Tag Label of the bypass group.

i
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6.4.1 Add Devices to an Output Zone

1. Click Output Zone in the Job Tree under Base I/O.

2. Click Insert in the menu bar, then click Add Zone.

The Add Output Zone window appears.

Figure 33 Add Output Zone

3. Enter the following information:

4. Click Close.

5. Select the new output zone.

6. Click Insert in the menu bar, then click Add Correlations.

Table 15 Output Zones

Column Description

Addr. Address of the output zone.

Type The process type of the output zone.

F1 NS: Non Silenceable - used on Signal or Strobe type.

F2 AR: Auxiliary Reset required - used on Relay type.

Tag The text of the tag, in a 20 character field.

Note: Output devices that are configured as the Signal or Strobe types are correlated 

to Fire Drill and Total Evacuation automatically. In order to add these devices to 

an output zone, delete their other correlations first.

Table 16 Add Output Zone

Name Description

Type Signal, Relay or Strobe.

Number to 

Add

Specify how many output zones to add by changing the Number to add 

value.

i
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The Select items to add window appears.

Figure 34 Select items to add to output zone

7. Select the output devices that you want to add. To select more than one device, hold 

down the Ctrl key and click the devices.

8. Click Add.

9. Select the input devices or system statuses that you want to correlate to the output zone.

10. Click Add.

11. Click Close.

6.5 Main Display

This window appears in the top, right pane when the Main Display item is selected in the Job 

Tree.

Table 17 Main Display

Name Description

User 

Messages

System Normal: specify the message to display on the front panel LCD 

when the system is currently normal (no alarm or trouble).

Passcodes Level 1, 2 and 3: Specify the passcode for each level of access. 

Passcodes must be numeric and a maximum of 20 digits long.
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6.6 Display Adder

This list appears in the top right pane when a display adder is selected in the Job Tree. The list 

displays items (LEDs and switches) on the selected Display Adder.

Access Levels Specify the level of access for various front panel actions.

Items assigned level 0 do not require a passcode.

The level 1 passcode has the lowest permission, and the level 3 

passcode has the highest permission.

For example, if you assign Loop Bypass the level 1 passcode, then a 

technician can access the loop bypass feature on the panel with the level 

1, 2 and 3 passcodes.

If you assign Loop Bypass the level 2 passcode, then a technician can 

access loop bypass with the level 2 and 3 passcodes, but not the level 1 

passcode.

If you assign Loop Bypass the level 3 passcode, then a technician can 

access loop bypass with the level 3 passcode only.

Once a technician enters a passcode, she can access other items in the 

menu without entering the passcode again, as long as the item is 

assigned the same passcode level or lower, and as long as she does not 

exit the Operation or Configuration menu.

Table 18 Display Adder Info

Name Visible Description

Idx Yes Index: the position of the item on the adder.

CPU No
The CPU Number of the annunciator to which the adder is 

attached.

Unnamed Yes

Linked Item: contains an asterisk if the item shares the 

same LedGrp with other items. This means that correlations 

to one such item are added to all linked items. Linked Items 

can be created when Paste Special is used. The linked 

items can be viewed with the Linked Items dialog.

Frame No

The Frame Number. An adder may contribute several 

frames to an annunciator. The frame numbers are zero 

based.

LED No

The number (zero based) of the first LED of a logical group. 

For example, a RAX-1048TZDS on the FX-401 has two 

LEDs per point. This column shows 0 for Idx 0, 2 for Idx 1, 

etc. Due to the way the LEDs are physically arranged on 

some adders, the LED numbers are in irregular sequences.

Sw No The switch number (if any) associated with the Idx.

Type Yes
The type of LED or switch. Double-click the type to change 

it. The list of types depends on the device.

Assignment Yes Dependent on the type.

Table 17 Main Display (Continued)

Name Description



42

6.7 Dialer

This form is displayed when the Dialer tree item is selected. It allows you to configure the 

Dialer. The dialer can dial out on two phone lines. You must configure an account and specify 

the line attributes for both. Line 2 can dial a cell phone. If this is the case the auto test can be 

reduced from daily to monthly.

6.7.1 Account 1

6.7.2 Account 2

6.7.3 Line 1

F1 Yes Not used.

F2 Yes Not used.

F3 Yes Not used.

Tag 1 Yes
Except for System Led and Bypass Zone, a 20 character tag 

can be entered. This tag identifies the control in messages.

Tag 2 Conditional Not used.

Table 19 Dialer Account 1

Name Description

Account ID Six digit decimal for the SIA report formats and four digit hexadecimal for 

Contact ID.

Telephone Text Field for telephone number.

Report Format Choose from SIA110, SIA300, Contact ID.

Table 20 Dialer Account 2

Name Description

Account ID Six digit decimal for the SIA report formats and four digit hexadecimal for 

Contact ID.

Telephone Text Field for telephone number.

Report Format Choose from SIA110, SIA300, Contact ID.

Table 21 Dialer Line 1

Name Description

Dial Using Tone or Pulse.

Wait Check to wait for dial tone before dialling.

Table 18 Display Adder Info (Continued)

Name Visible Description
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6.7.4 Line 2

6.7.5 Report Priority

6.7.6 Timers

6.7.7 Lines 1 and 2 Test Times

If the Line 2 cellular test is disabled, then the dialer alternates between Lines 1 and 2 when 

performing the automatic test. If the Line 2 cellular test is enabled, then the automatic test is 

Table 22 Dialer Line 2

Name Description

Dial Using Tone or Pulse.

Wait Check to wait for dial tone before dialling.

Table 23 Dialer Report Priority

Name Description

Alarm Choose one of the two accounts to use to report Alarms.

Supv Choose one of the two accounts to use to report Supervisory alerts.

Trouble Choose one of the two accounts to use to report Troubles.

Table 24 Dialer Timers

Name Description

AC loss delay 0-20 hours. Use this menu to delay the reporting of AC loss trouble on 

the dialer for the programmed time period.

Line 2 cellular 

test

To comply with UL 864 10th edition, leave this setting unchecked.

Use this menu to set the test report date for the cell phone setup. 

Uncheck this box if there is no test reporting for a cell phone, or if the 

phone line is a regular line. Set Day of month from 1 to 28 to schedule a 

test for Line 2 on a certain day of the month. See section 6.7.7 for more 

information.

When a cell phone service is employed for the panel, it should only be 

connected to telephone line #2 CO interface. Also, the dial tone detection 

feature of Line 2 should be disabled for cell phone application.

Auto test at Use this function to set the time for the automatic test. When this test is 

performed, the test report is sent to the monitoring station. To comply 

with UL 864 10th edition, this test must be performed at least once every 

6 hours.

The Auto test time can be configured to:

12:00 a.m. to 5:59 a.m.: test every 24 hours

6:00 a.m. to 11:59 a.m.: test every 6 hours

12:00 p.m. to 23:59 p.m.: test every 12 hours

If the Line 2 cellular test is disabled, then the test alternates between Line 

1 and Line 2. See section 6.7.7 for more information.
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performed on Line 1 except on the day of the Line 2 cellular test, when it is performed on Line 

2. See examples in Table 25.

6.7.8 Dialer

6.7.9 Advanced CID Report

Selecting “Advanced CID Report” generates a CSV file with an Input and Output Summary. 

This sheet features columns for Circuit Number (CktNo), Loop, Device Address (Addr), Sub-

Address (Sub-Addr), Contact ID (GGCCC), UDACT Reference (SIA), Device Type, and Tag. 

In the Contact ID, “GG” denotes the loop and sub-address with two digits, and “CCC” indicates 

the device address with three digits.

Send this report to the receiving station.

Table 25 Lines 1 and 2 Test Times

Line 2 cellular 
test

Auto test at Line 1 Tested Line 2 Tested

Disabled 00:30
12:30 a.m. every other day 

(alternates with Line 2)

12:30 a.m. every other day 

(alternates with Line 1)

Disabled 6:00 6:00 a.m. and 6:00 p.m. 12:00 p.m. and 12:00 a.m.

Disabled 12:00 12:00 p.m. 12:00 a.m.

Day of month: 15 00:30

12:30 a.m. every day 

except on the 15th of the 

month

12:30 a.m. on the 15th of 

the month

Day of month: 15 6:00

6:00 a.m., 12:00 p.m., 6:00 

p.m., and 12:00 a.m. every 

day except on the 15th of 

the month

6:00 a.m., 12:00 p.m., 6:00 

p.m., and 12:00 a.m. on 

the 15th of the month

Day of month: 15 12:00

12:00 p.m. and 12:00 a.m. 

every day except on the 

15th of the month

12:00 p.m. and 12:00 a.m. 

on the 15th of the month

Table 26 Dialer

Name Description

Line Retries Specify the number of retries to make (5-10).

Rings Specify the number of rings when dialing in to configure. Warning: if set to 

zero the next dial in session will not be able to connect.

Mode Choose between DACT and UDACT.

Enable Uncheck this box if you wish to set the dialer to the disabled state when 

you send the job to the panel. If you receive a job from the panel when 

the dialer was temporarily disabled then this check box will be 

unchecked. The dialer is enabled by default.

Aux 

disconnect

If enabled, the dialer blocks the alarm and supervisory events from being 

reported after the auxiliary disconnect button is pressed.
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Here is an example of an Advanced CID Report:

Figure 35 Advanced CID Report

In row 3 of Figure 35, the Circuit Number (CktNo) is 0, Loop is 1, Device Address (Addr) is 6, 

and Sub-Address (Sub-Addr) is 1, the Contact ID (GG CCC) appears as CID (11 006).

GG represents the loop and sub-address. In this example, 11 represents loop 1 and sub 

address 1. See table 27 for the complete list of correspondences.

CCC is the device address. In this example, 006 represents device address 6.

Table 27 Contact ID Loop and Sub-Address Conversion Table
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6.8 Common System Status

This list appears in the top right pane when the Common System Status item is selected in the 

Job Tree.

System Statuses are virtual inputs that can be correlated to outputs. For example:

� Correlate a signal circuit to operate as a power supply. (using Init Done).

� Customize the Fire Drill operation.

� Correlate a relay to operate on Reset Command (using Sys Reset).

6.9 Input Summary and Output Summary

The Job Tree always contains an Input Summary and Output Summary item. Select either of 

these items to see a list of all of the circuits on the job.

The Input Summary gives an Input UDACT reference number and tag required for 

programming by the Central Monitoring Station. On products that support them, this list may 

include Correlatable Switches. These do not have a value in the Loop and Address columns.

The Output Summary gives an output UDACT reference number and tag required for 

programming by the Central Monitoring Station.

6.10 Subsequent Alarm Per Zone

This feature lets you correlate devices to zones, which are represented by the LEDs of the 

RAX-1048TZDS. If an alarm is activated in a zone, and the signals are silenced, then a 

subsequent alarm in the same zone does not resound the signals. However, a subsequent 

alarm in a different zone does resound the signals.

6.10.1 Configuration

To configure Subsequent Alarm Per Zone for a job:

1. In the Job Details section of the job you want to edit, enable the Subsequent Alarm 

Per Zone option.

Figure 36 Job Details

Note: This feature is for Canadian applications only.i
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2. Add Correlations - Signal(s)

a. Right-click on each input device and click on Add Correlations to initiate adding 

Signal(s).

Figure 37 Add correlations to each input device

b. Choose the Signal(s) you wish to add.

Figure 38 Select Signal(s)

3. Add a Display Adder - RAX-1048 TZ (DS)

a. Click Insert in the top panel or right-click on Main Display and select Add Display 

Adder.

Figure 39 Add Display Adder

b. Select RAX-1048 TZ (DS).

Figure 40 Select Adder Type
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4. Create Zones.

a. Click on RAX-1048 TZ (DS) under Main Display.

b. To create a zone, double-click on an unassigned zone Type and assign a zone.

For this process select Ipt Zone.

Figure 41 Select type of zone

5. Correlate devices to each Zone.

a. Right-click on each zone you've created to add a correlation.

Figure 42 Add correlations to each zone

b. Choose the devices you wish to add to the zone.

Figure 43 Add device(s) to zone



49

6.10.2 Operation

Below are three scenarios that explain the operation of the Subsequent Alarm Per Zone.

Figure 44 Scenario 1

Table 28 Scenario 1 steps and results

Step Result

Activate Device 1 in Zone-1 NAC-1 is activated

Perform Signal Silence NAC-1 is silenced

Activate Device 2 in Zone-1 Buzzer activated (NACs remain silent)

Activate Device 3 in Zone-2 NAC-1 and NAC-2 are activated

Perform Signal Silence NAC-1 and NAC-2 are silenced

Activate Device 4 in Zone-2 Buzzer activated (NACs remain silent)

Note: The bold line between the devices and NACs indicates their connection, while the 

dotted line encapsulates the zone containing the devices.

If an alarm is activated in a zone, and the signals are silenced, then a subsequent 

alarm in the same zone does not resound the signals. However, a subsequent 

alarm in a different zone does resound the signals.

Device 1 Device 2

NAC-1

Zone 1

Device 3 Device 4

NAC-2

Zone 2

i
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Figure 45 Scenario 2

Table 29 Scenario 2 steps and results

Step Result

Activate Device 1 in Zone-1 NAC-1, NAC-2, NAC-3 and NAC-4 are activated

Perform Signal Silence NAC-1, NAC-2, NAC-3 and NAC-4 are silenced

Activate Device 2 in Zone-1 Buzzer activated (NACs remain silent)

Activate Device 3 in Zone-2 NAC-1, NAC-2, NAC-3 and NAC-4 are activated

Perform Signal Silence NAC-1, NAC-2, NAC-3 and NAC-4 are silenced

Activate Device 4 in Zone-2 Buzzer activated (NACs remain silent)

Note: The bold line between the devices and NACs indicates their connection, while the 

dotted line encapsulates the zone containing the devices.

If an alarm is activated in a zone, and the signals are silenced, then a subsequent 

alarm in the same zone does not resound the signals. However, a subsequent 

alarm in a different zone does resound the signals.

Device 1 Device 2

NAC-1

Zone 1

Device 3 Device 4 Zone 2

NAC-2

NAC-3

NAC-4

i
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Figure 46 Scenario 3

Table 30 Scenario 3 steps and results

Step Result

Activate Device 1 in Zone-1 NAC-1 is activated

Perform Signal Silence NAC-1 is silenced

Activate Device 2 in Zone-1 Buzzer activated (NACs remain silent)

Activate Device 3 in Zone-1 Buzzer activated (NACs remain silent)

Activate Device 4 in Zone-2 NAC-1, NAC-2 and NAC-3 are activated

Perform Signal Silence NAC-1, NAC-2 and NAC-3 are silenced

Activate Device 5 in Zone-2 Buzzer activated (NACs remain silent)

Note: The bold line between the devices and NACs indicates their connection, while the 

dotted line encapsulates the zone containing the devices.

If an alarm is activated in a zone, and the signals are silenced, then a subsequent 

alarm in the same zone does not resound the signals. However, a subsequent 

alarm in a different zone does resound the signals.

Device 1 Device 2 Zone 1

Device 4 Device 5 Zone 2

NAC-3

Device 3

NAC-1 NAC-2

i
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7.0 Add Items to the Job

7.1 Add a Loop Controller (FX-401 Only)

To add an ALC-480 Dual Loop Adder

1. Click Insert, then click Add Loop Controllers.

Loop 2 and Loop 3 appear in the Job Tree under Base I/O.

7.2 Add Annunciator

To add an annunciator

1. Click Insert, then click Add Annunciators.

2. In the Add Annunciator window enter the following information:

3. Click Close to close the Add Annunciator window.

7.3 Add Correlations

The Add Correlations window shows a tab for every category of circuit or display item that 

can be correlated to the items selected in the Details Pane.

The content of each tab is updated as correlations are added or deleted so that the window 

always shows the items that are available.

Table 31 Add Annunciator

Name Description

Select Type Select the type of Annunciator to be added to the job.

Number to 

add
Edit this number to add more than one Annunciator to the job.

Tag Not used.

Add Click Add to add the annunciator. The Job Tree shows the new 

Annunciator. If the limit for the job is exceeded an error message 

appears.
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To add correlations

1. From the Details Pane right click an item and select Add Correlations.

The Add Correlations window appears.

Figure 47 Add Correlations Window

2. Select the items to be correlated, then click the Add button.

You can hold down the Ctrl key to select multiple rows.

3. Click Close to close the window.

7.4 Add Device

To add devices

1. In the Job Tree, select a loop.

2. Click Insert, then click Add Device.

The Add Devices window appears.

Figure 48 Add Devices window
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3. Enter the following information:

4. Click Add.

If there are not enough addresses, an error message appears.

� Click OK to cancel the procedure. The Configurator does not add any devices.

After the operation is complete, the window remains open. The Address value is 

adjusted to account for the devices just added.

If there are no available addresses for the chosen Type, then the Add button is disabled.

5. Click Close to close the window.

7.4.1 INX-10A Templates

This feature allows all corresponding devices required for INX-10A to be automatically added.

Figure 49 INX-10A template

1. Select “INX-10A” in Type.

2. From Options, choose one of the following::

� Single-Stage & Basic Report

Table 32 Add Device

Name Description

Type The major device type.

Options The available options depend on the device.

Process As Choose the type of alarm that you want to associate with this device.

Address Specify the address for the new device. This defaults to the lowest 

available address for the chosen type.

Number to 

Add

Specify how many devices to add by changing the Number to add 

value. The Configurator attempts to allocate the devices sequentially, 

starting with the address you selected.

CO Alarm Not available

Corr with Base Available when a detector is selected in Type and an addressable base 

is selected in Options. When checked, the addressable base is 

correlated with the detector.
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� Single-Stage & Enhanced Report

� Two-Stage & Basic Report

� Two-Stage & Enhanced Report

3. From NAC Settings, select one of the following:

� None

� Use NAC5 as Power Supply

� Use NAC4 & NAC5 as Power Supply

4. Select an Address.

5. Number to add, CO Alarm, and Corr with Base are unavailable for this template.

6. Click Add.

7.4.2 Device Addressing

MIX-4000 series device addresses are in the form n.n.

� The number before the period represents the address that is set on the device with the 

programming tool (the physical address).

� The number after the period is a subaddress. This is a virtual address that the 

Configurator uses to refer to the device. A device has one physical address but can have 

many subaddresses.

For example, when you add a Photo (4010) with the physical address 1, it appears as an entry 

with the address 1.1.

Figure 50 Photo (4010) with the address 1

Some devices have two or more subaddresses. When you add one of these devices, 

additional subaddresses are automatically created for the additional inputs or outputs.

For example, a PhotoH 135 (4020) with the address 1 has the following entries:

� PhotoH 135 (4020): 1.1 (first input)

� Heat: 1.2 (second input)

Figure 51 PhotoH 135 (4020) with the address 1

A class B Dual Input (4040/1) with the address 1 has the following entries:

� Dual Input (4040/1): 1.1 (first input)
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� Input: 1.2 (second input)

Figure 52 Class B Dual Input (4040/1) with the address 1

A class B 12-Input (4040-M) with the address 1 has the following entries:

� 12-Input (4040-M): 1.01 (first input)

� Input: 1.02 (second input)

� Input: 1.03 (third input)

� Input: 1.04 (fourth input)

� Input: 1.05 (fifth input)

� Input: 1.06 (sixth input)

� Input: 1.07 (seventh input)

� Input: 1.08 (eighth input)

� Input: 1.09 (ninth input)

� Input: 1.10 (tenth input)

� Input: 1.11 (eleventh input)

� Input: 1.12 (twelfth input)

Figure 53 Class B 12-Input (4040-M) with the address 1

7.4.3 Add a Base to a Device

When you add some devices (for example the Photo (4010)), you have the option to add a 

base to the sensor head.

� NAB (Non-Addr. Base): non-addressable base

� ASB (Addr. Sounder Base): addressable sounder base

� ARB (Addr. Relay Base): addressable relay base
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� ALB (Addr. Low-Freq Base): not used

Figure 54 Base selection

When you add a device with an addressable base, the base is assigned a subaddress. For 

example, a Photo (4010) at address 1.1 has an addressable sounder base at 1.2.

Figure 55 Photo (4010) with addressable sounder base

7.4.4 Add a Class A or Class B Device

Some devices have the option of being class A or class B. By default, these devices are 

class B.

For example, a Dual Input (4040/1) has two entries by default.

Figure 56 Class B Dual Input (4040/1)

If you select Class A in the Options menu when you add the device, then it has one entry.

Figure 57 Class A Dual Input (4040/1)
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7.4.5 Convert a Device to Class A or Class B

To convert a class B device to class A, follow these steps:

1. Double-click Class B in the Options column for the device.

2. Select Class A in the menu that appears.

Figure 58 Convert a device to class A

The Configurator deletes subaddresses as necessary.

To convert a class A device to class B, select Class B in the Options column. The 

Configurator adds subaddresses as necessary.

7.4.6 Add a Manual Station

To add a manual station, for example MPS-802MP or MPS-810MP(U), follow these steps:

1. In the Add Devices window, select Dual Input (4040/1) in the Type menu.

2. Click the Options menu, and select Class A for a single stage manual station and 

Class B for a two stage manual station.

3. Select Alarm Input in the Process as menu.

4. Click Add.

For example, to add a two stage manual station like MS-402MP, add Dual Input (4040/1) and 

select Class B in the Options menu. The first input is the pull handle and the second input is 

the stage two key.

Figure 59 Two stage manual station

To add a single stage manual station like MPS-810MP(U), add Dual Input (4040/1) and select 

Class A in the Options menu.

Figure 60 Single stage manual station

By default, Dual Input (4040/1) is added as class B. To convert a class B device to class A, 

follow the steps in section 7.4.5.
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7.5 Add Display Adder

Figure 61 Add Display Adder window

To add a display adder

1. In the Job Tree, right-click one of the listed annunciators and select Add Display Adder.

The Add Display Adder window appears.

2. From the drop down menu select the desired Display Adder.

3. Click Add.

4. Click Close to close the Add Display Adder window.

7.6 Add IPS-2424DS and IPS-4848DS

Add an IPS-2424DS

1. Select the annunciator or display adder that you want to add the IPS-4848 to.

2. Click Insert in the menu bar, then click Add Display Adder.

3. Select 24 Sw Adder in the Select Adder Type pulldown menu.

4. Click Add.

Add an IPS-4848DS

1. Select the annunciator or display adder that you want to add the IPS-4848 to.

2. Click Insert in the menu bar, then click Add Display Adder.

3. Select 48 Sw Adder in the Select Adder Type pulldown menu.

4. Click Add.

7.7 Configure IPS-2424DS and IPS-4848DS to Operate a Bypass 

Group

You can correlate any input or output device to a group, as well as an LED to indicate its 

status. After an LED is correlated to a bypass group, it will be used exclusively to indicate the 

status of that group and it can not be used for other purpose.
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Create a bypass switch

1. Select the 24 Sw Adder or 48 Sw Adder.

By default, all the switches are unassigned.

2. Double-click <unassigned> in the Type column for a switch, and select Byp Zone.

In Figure 62, switch 0 on the 24 Sw Adder is a bypass switch.

Figure 62 Bypass switch

Create a bypass group

1. Select Bypass Groups under Base I/O.

2. Click Insert in the menu bar, then click Add Group.

A new bypass group appears with the name New Grp.

Figure 63 New bypass group

3. Double-click the name of the new group and type a descriptive name.

4. Right-click the bypass group, then click Add Correlations.

The Select items to add window appears.

Figure 64 Select items to add to bypass group

5. Select the devices that you want to add. To select more than one device, hold down the 

Ctrl key and click the devices.

6. Click Add.



61

7. In the Select items to add window, click the Display tab and select the adder switch to 

assign to this bypass group, then click Add.

Figure 65 shows the bypass switch created in "Create a bypass switch" on page 60 

Figure 65 Add switch to bypass group

8. Click Close.

7.8 Delete Correlations

To delete a correlation

1. Click the correlation, then click the Edit menu, then click Delete Item. Hold down the 

Shift key to select more than one correlation at once.

2. Click Yes to delete the correlation.

7.9 Import and Export Tags

You can export the tags as a CSV (comma separated values) file that you can open in a 

spreadsheet editor. Then you can edit the tags, and import the CSV file back into the MGC-

400 Configurator.

To export tags

1. Click Job > Export Tags.

2. Choose a location and click Save.

The file is saved with the job name, number and version.

Figure 66 Example CSV file with exported tags
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To import tags

1. Edit the tags in the CSV file as desired.

2. Click Job > Import Tags.

3. Select the CSV file and click Open.

The new tags are imported and the previous tags in the job are overwritten.

Note: Do not make any other changes to the CSV file other than names of tags. If you 

edit any of the other columns, the job might become unusable.

Attention: When you import tags, the tags in the job file are deleted and replaced 

with the tags in the CSV file.

i

!
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8.0 Manage the Database

The database stores all jobs and their information. You can back up, restore or compact 

databases.

8.1 Backup Database

The Backup Database command makes a copy of the Master Database.

Figure 67 Backup Database

To back up the database

1. Click File > Backup Database. The file location specified in the User Preferences 

appears. The file name is in the form YYYY-MM-DD.mdb.

2. Click Save. A popup window appears notifying you of a successful backup.

The backup can be used by the Restore Database command to recover all of the jobs in the 

database. You can also use the Import command to recover selected jobs from a backup. 

Backup your Master Database often and store a copy of the resulting file on a CD or other 

media.

Note: If the Keep Only Latest Versions After Backup option is enabled in User 

Preferences, old versions of each job in your main database will be deleted when 

you back up the database. Only the latest version of each job will be kept.i



64

8.2 Restore Database

The Restore Database command reads a database file and imports every job found there, 

after first deleting all of the jobs in the current database. If the backup database was produced 

by an older version of the configuration tool, all necessary conversion is performed. 

Conversion is sometimes necessary when a new version of the configuration tool is released. 

The install program makes a backup and instructs you to run Restore Database to convert all 

of your jobs.

Figure 68 Restore Database

To restore a database

1. Click File > Restore Database and a warning appears.

Figure 69 Restore Database

Warning: When you restore from an older backup you will lose any changes that 

have been made since the time of the backup.!
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2. Click Yes to continue.

3. The file location specified in the User Preferences appears and the file name is in the 

form YYYY-MM-DD.mdb.

4. Select the desired database and click Open.

A popup window appears notifying you of a successful restore.

8.3 Compact Database

A database that has been the subject of many deletions and additions can become 

fragmented and occupy more space than required. Compact Database runs a standard MS-

Access utility to recover the space and improve performance.

To compact a database

1. Click File > Compact Database.

A status window appears. There is no further notification.

Note: This may take several minutes for a large database.i
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9.0 Manage Jobs

9.1 Create a New Job

Figure 70 Create Job window

To create a new job

1. Click Job, then click New Job.

The Create Job window appears.

2. Enter the information in Table 33, then click OK.

Table 33 New Job

Name Description

Enter description for new 

job

This name, which should be unique, identifies the job 

throughout its lifetime. Note that in a multi-product 

environment the same job name cannot be used for jobs 

of different products, even if you do not currently have 

access to all possible products. An error message 

appears if the name is not unique. The error message 

helps you identify duplicates that belong to other products 

or brands.

Author The technician who is creating the new job. The default is 

automatically inserted but can be overridden.

Comments (Must be entered) Enter a comment. It can span multiple lines. This 

becomes part of the job's version history.

Model Choose the panel model for your new job.

Template (optional) Select a template to start from.

Copy current job data As an alternative to choosing a template and panel 

model, check this box to make a copy of the job which is 

currently open in the Configurator.
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9.2 Open Job

Figure 71 Select Job and Version window

The Open Job command lets you select a job and version in the database and open it. The 

Select Job list shows all of the jobs in the database. Click the column heading to sort the jobs 

by:

� Job Number

� Job Description

� Product (where more than one product is supported)

The Select Version list shows all of the versions of the selected job. This includes the date and 

a description.

To open a job

1. Click Job, then click Open Job.

The Select Job and Version window appears.

2. Select the Job and click OK.
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9.3 Import Job

Figure 72 Import Job window

The Import Job command imports a selected job version from an external database or 

serialized job archive as created by the Export Job or Backup Database commands. and 

converts the job to the current version if necessary. Choose the type (MDB or Serialized 

Archive) and location of the file to read. The location defaults to the Job File folder specified in 

User Preferences.

If the selected type is MDB, then the Microsoft Access database (usually a database that 

resulted from a Backup Database) is opened. A list, similar to the Open Job window, displays 

jobs contained in the database.

The chosen job is copied to the current database. If the version of the source database is not 

too old (no forward conversion is possible) and is not younger than the current database, then 

any necessary conversion is performed. If the database version is not compatible, an error 

appears.

If the selected type is fx2job (a serialized archive, usually the result of Export Job) then the 

Jobs found in the archive's index are listed. The program converts the job to the current 

standard, and stores the job in the database.

If the same job (identified by its name) is already in the database, then the next highest version 

number is assigned to the job.

If a job with the same name is not on the database, then a new job is created.

To import a job

1. Click Job > Import Job.

The Select a file to import from window appears.

2. Select the Job and click OK.
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9.4 Export Job

Figure 73 Export Job window

Use the Export Job command to share a job, for example between technicians. The fx2job 

format results in a very small file, suitable for electronic transmission.

By default, the file is given a name Jobnn-vv where nn is the job number and vv is the 

version. You can change the name to make it easier to identify the job.

To export a job

1. Click Job > Export Job and the Export Job window appears.

2. Select the file type to export.

3. Click Save.

9.5 New Version

To create a new job version

1. Click Job > New Version.

The New Job Version window appears.

2. Enter the name of the technician making the change, any related comments and click 

OK.

9.6 Delete Job Version

Deleting the Job Version deletes the currently open Job from the Database. When a job is 

deleted, it will no longer be accessible from the Version History window.

Table 34 Export Job

Name Description

.mdb A Microsoft Access database containing a single job is produced.

.fx2Job A compact archive file is produced.

OpenGN Not used.

OpenGN Phase II Select this file type to produce an XML file to import into OpenGN.
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To delete the currently open job version

1. Click Job > Delete Job Version.

A window appears asking if you want to permanently delete the currently open version.

2. Click OK.

9.7 Version History

Figure 74 Version History window

The version history of the current job is displayed in list form, beginning with the most recent 

version.

To open the Version History Window

1. Click Job > Version History. The version history window appears.

2. Click OK to close the window.

Table 35 Version History

Name Description

Number The version number. Each time a new version is created, either with 

the New Version command or by getting a job from the panel or an 

archive, a new version number is assigned.

Date The date and time the version was created.

Changed by The user who created the version.

Description The description, which was entered when the new job version was 

created.

Type Uploaded: the new job version was a result of a Get Job.

New Job: the user created a new version manually.

Status Locked: the job has been sent to the panel and cannot be edited.

Editable: the job is editable.
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9.8 Compare Job Versions

For details on Comparing Jobs and Differences mode see section 13.

Figure 75 Select Job to Compare window

Table 36 Select Job to Compare

Name Description

Primary Job This field lists the job number and version that the 

secondary job should be compared with.

Secondary Job to compare Use the combination of Job and Version to select the 

secondary job. Normally you would choose a newer 

version of the same job. You cannot choose the same Job 

and Version for Primary and Secondary.

You can sort the list of secondary jobs by Job Number, 

Description or Product.

Show Identical Items Check this box if you want to see not only changes, but 

also those items that stayed the same. Normally you 

would leave this unchecked. Differences are easier to see 

and Print generates less output if identical items are not 

included.

Advanced Options Click Advanced Options to open the Advanced Options 

window. Here you can change some of the more 

advanced filtering options. They are checked by default 

and in most situations do not need to be changed.

See section 9.8.1.
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To compare jobs

1. Click Job > Compare Job Versions.

The Select Job to Compare window appears.

2. Select the Secondary Job, Version, if you would like to show identical Items and any 

Advanced Options. For more information see section 9.8.1.

3. Click OK to open Differences Mode.

9.8.1 Advanced Compare Options

Figure 76 Advanced Compare Options window

Table 37 Advanced Compare Options

Name Description

Modified Check this box to include any item that has been modified. (Modified 

means that it is the same adder, circuit, or switch but some attribute 

has been changed.) You should only uncheck this box if you do not 

want to see items that have been modified.

Present only in 

Secondary Job

Check this box to include items that are only present in the secondary 

job. This means that Loop Adders, Annunciators, Display Adders, and 

circuits that were not on the primary job are included. You should only 

uncheck this box if you do not want to have new additions reported.

Present only in 

Primary Job

Check this box to include items that were only present in the primary 

job. This means that Loop Adders, Annunciators, Display Adders, and 

circuits that were removed from the primary job are included. You 

should only uncheck this box if you do not want to have deletions 

reported.
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9.9 Validate Job

To validate a job

1. Click Job > Validate Job.

If there are errors with the job, a window appears with a message about the errors.

9.10 Edit Job

When you open a job, whether by getting it from the panel or opening it from the database, it is 

locked by default, and you must unlock it in order to edit it.

Edit a job

� Click Job > Edit Job.

If you try to edit a locked job that has not been sent to a panel, a message appears asking if 

you want to make it editable.

Figure 77 This job is protected against unintentional edits

� Click Yes to unlock the job.

Note: Filtering of Present only in Secondary and Present only in Primary do not 

apply when presenting the tree. The tree is shown in its entirety, regardless of 

these settings. The filtering is only applied to the Device, Display Item and similar 

lists. It is intended to make it easy to see what components have been physically 

added or removed from the job.

Correlations are not considered to be items in this context. If a correlation was 

added, then that is effectively a modification to the item that received the 

correlation.

If you check Present only in Secondary, or Present only in Primary, or both, 

but you do not check Modified, then the items that have only had correlation 

changes are not included.

i
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If you try to edit a job that has been sent to a panel, a message appears saying that you 

should create a new version. See section 9.5.

Figure 78 This job version has already been built or downloaded to the panel



75

10.0 Work with the Panel

10.1 Send Job

To send a job to the panel

1. Click Panel > Send Job.

2. Click Yes.

Once the job has been successfully sent a confirmation window appears.

3. Click OK.

10.2 Get Job

To get a job from the panel

1. Click Panel > Get Job.

The Create Job window appears.

2. Enter the job information and click OK.

Once the job has been retrieved a confirmation window appears.

3. Click OK.

10.3 Enable Quick Send

This command enables faster data transfer to the panel by sending only changed data 

structures instead of the full job file. Transfer time is reduced. Once enabled, Quick Send 

remains active until it is unchecked.

10.4 Panel Information

This command displays information on the panel and the Configurator, with options to view 

more detail. The information includes:

� The Product Version

� Name and Version of the job currently loaded on the panel

� Panel Model

� The Date it was sent

� The ESD and Tech who sent or owns the job. (For products secured with a key)

� Security Key SIN. (For products secured with a key)

� Config Version

� Date and Time Last Changed

� Number of times auto configured

� The Panel Time
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Click the Update button to update the panel time with the time from the Configurator for those 

products that support the feature.

Figure 79 Panel Information

10.4.1 Advanced Panel Information

Click the Advanced button to see more information. This information may not appear for all 

annunciators.

The following information is displayed:

� Node - address

� Type - CPU Type

� Version - current firmware version (n/a for RA1000)

� Language - language in firmware (standard messages/menu etc.)

� System Type - one of the following:

� Compact Build

� Large Build

� HW Type - "base" or "Exp. Master" for the Large board

� HW Vers - currently always VX.X.X

� Status - one of the following:

� Online

� Not responding

� Wrong type (configured as "xxxx" )

� Unconfigured CPU

� Firmware version mismatch

� Address mismatch (configured as node xx)

� Offline trouble: xxx xxx
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Figure 80 Advanced Panel Information

10.5 Event Log

The Event Log window has two tabs, one for the General log and one for the Alarm log. The 

operations of each tab are identical. When the window appears, the currently active tab reads 

information from the panel and displays it.

A status field at the bottom of the window shows the progress of displaying the events. Events 

are shown on a list with the columns: No., Date and Time and Event Description. Scroll the list 

up or down to see more events. New events are automatically added to the top of the list.

You can stop the process of displaying the events by clicking the Stop button. To re-load the 

list, click the Refresh button.

Click the Export button to export the list of the active tab to a CSV file. The CSV file can be 

imported to spreadsheet software such as Microsoft Excel for further analysis.

Click Close to close the window.

10.6 Modify Mode

Modify mode lets you change options, tags, correlations, and process types on the panel 

without getting the job. This can be useful if you do not have a copy of the job but you need to 

change something quickly. For example, after you use the panel’s Auto Config feature 

(described in the FX-400/401 installation manuals LT-6670 and LT-6671), you can use modify 

mode to make small adjustments to the job.

Enter modify mode

1. Click Panel > Modify Mode.

When you are in modify mode, Modify Mode is checked in the Panel menu.

Figure 81 Modify Mode is checked in the Panel menu



78

2. Make changes to the options, tags, correlations or process types. Options refer to the 

checkboxes in the Options box in the Job Details (see section 6.1.3). Process type 

refers to the information in the loop’s Type column.

3. After you made changes to options, click Panel > Quick Update > Update Options.

4. After you made changes to tags, click Panel > Quick Update > Update Tags.

5. After you made changes to correlations, click Panel > Quick Update > Update 

Correlations.

6. After you made changes to types, click Panel > Quick Update > Update Process 

Types.

The options, tags and correlations are updated on the panel immediately.

7. Click Panel > Modify Mode to exit modify mode.

The Configurator asks if you want to exit Modify Mode.

8. Click Yes to exit Modify Mode.

Figure 82 Exit modify mode

The system asks if you want to get the job for backup.

9. Click Yes to get the job.

Figure 83 Do you want to get the job for backup

10. If you click Yes, the Create Job window appears. Enter the description and comments for 

the job, then click OK.

Note: When you are in modify mode, you are working with the active job on the 

panel, not the job that is open in the Configurator.

Note: If you make a change to options, tags, or correlations but you do not click 

the corresponding Quick Update, then your changes will not be applied to 

the panel when you exit modify mode.

Note: If you do not get the job, then you will not have a copy of the job that you 

just modified.

i

i

i
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10.7 Upgrade Firmware through the Micro-B USB Port on the Core 

Board

You need the following items in order to upgrade the firmware on the FX-400 and FX-401:

� Windows 10 computer with a USB port.

� USB A plug to micro-B plug cable.

� MGC-400 Series Configuration Utility (the Configurator).

� A copy of the firmware.

Upgrade the firmware

1. Follow the instructions in section 1.3 to connect a micro-B USB cable from the laptop to 

the panel.

Figure 84 Micro-B USB Port on the core board

Attention: In some cases, the CPU light will flash during the firmware upgrade 

process. This is normal.!

JW4 JW5

Core Board

Micro-B USB Port
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2. In the MGC-400 Configurator, click File - User Preferences.

3. In the Serial Port menu, select the COM port that the USB cable is using.

Figure 85 Select the COM port in User Preferences

4. Click OK to close the User Preferences window.

5. Click Panel > Upgrade Firmware.

The Upgrade Firmware Wizard appears:

Figure 86 Upgrade Firmware Wizard

6. Click Browse and select the firmware file.

7. Click Next.

8. Follow the instructions in the next window:

a. Disconnect AC power and batteries in order to fully remove power from the panel.

b. Disconnect the micro-B USB cable from the plug-in core board.

c. Remove the jumper from JW4 on the plug-in core board and place it on JW5. See 

Figure 84 for a picture of the core board.
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d. Reconnect the micro-B USB cable to the plug-in core board.

Figure 87 Upgrade Firmware Wizard

9. Click Next.

A window appears showing the firmware upgrade status.

Figure 88 Upgrade Firmware Wizard: Sending file
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10. After the file is sent successfully, click Next.

Figure 89 Upgrade Firmware Wizard: The panel is upgraded successfully

11. On the next window, click Finish.I

Figure 90 Upgrade Firmware Wizard: Click Finish to complete the process

12. Disconnect the micro-B USB cable.

13. Remove the jumper from JW5 and place it on JW4. See Figure 84 for a picture of the 

core board.

14. Restore power to the panel.

Note: During normal operation, the JW4 jumper is closed and the JW5 jumper is open.i
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11.0 Tools Menu

11.1 Extract All DB

This command extracts every job on the database and produces an individual database file for 

each. It has the same effect as running Export Job for every job. Unlike Export Job, you do not 

have the choice of making a compact serial archive (FX2Job).

11.2 Validate All

This command validates the latest version of every job on the database. It also produces a C 

file for each job and stores it in the Job Build folder.

It has the same effect as using Validate Job on each job. Before the process starts, it displays 

the Build Job dialog so that you can specify the version of the product to be built.

11.3 Build Job

This command validates and builds the current job, producing a C file in the Job Build folder.

It performs the build assuming the latest product version.

11.4 Build Job (old versions)

This command validates and builds the current job, producing a C file in the Job Build folder.

It first shows the Build dialog so that you can choose the product version. You can use this 

command to produce the C files for older versions of the panel.

11.5 Link Statistics

This command displays statistics for the connection between the Configurator and the fire 

alarm panel.

11.6 Log Send

Toggle the current state of the "dump on send" option. Causes the ".c" file to be produced and 

dumped on a Get Job.

11.7 Log Get

Toggle the current state of the "dump on get" option. Causes the ".c" file to be produced and 

dumped on a Send Get.

11.8 Log Comms

Toggles logging of serial communications.
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11.9 Trace

Toggles the current state of the trace option. When turned on this causes debug information to 

be written to a trace file

11.10 Display Structure

This utility allows you to view the contents of a panel data structure. You have the option of 

continually retrieving and displaying the same structure at a refresh rate you specify. You can 

also log the results to a file.

To display a structure

1. Connect to the panel and click Display Structure under the Tools menu (you must have 

selected Show Tools Menu under preferences). The following dialog appears. 

2. Choose the CPU.

3. Choose the Structure on that CPU. Loop structures are qualified with a loop number. e.g. 

gLCUPollData - Loop 2.

4. Choose the entry (for Poll Data there is one entry per device, other structures may be 

organized differently.

5. Choose how many entries to display. The maximum is adjusted automatically to 

compensate for the selected start entry.

6. You can get a "one shot" display by pressing Refresh.

7. To run continuously, select a refresh rate and press Start.

8. To log to file check the Log To File box and specify a destination file.

9. You can adjust the refresh rate, the start entry and the number of entries while the 

display is running. They take effect after the next interval has expired.

10. To view a different structure you must first press stop.

11.11 External Bus

Toggles the "Use External Bus" setting. When turned on, this signals that the Configurator is 

connected to the External Bus of the panel.

11.12 About MGC-400 Series Configuration Utility

Displays the copyright notice and version number of your copy of the Configuration Utility.

Note: The actual entries on the panel may be less than the maximum. If you choose a 

start entry higher than the actual number of entries on the panel, an error 

message appears. If you choose a number of entries greater than those actually 

on the panel, only those that are present are displayed.
i
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11.13 Paste Special - Circuits, Adders or Entire Loops

This window appears in response to a Paste Special when pasting circuits, conventional 

adders or entire loops.

Figure 91 Paste Special

The text summarizes what is being pasted and its destination, for example pasting three 

devices to loop 2.

Table 38 Paste Special - Circuits, Adders or Entire Loops

Name Description

Number of copies Enter the number of copies to make. The paste operation 

attempts to make the specified number of copies. If the 

capacity of the destination is exceeded a message 

appears saying how many copies were successfully 

made. 

Copy I/O correlations Check this box to include I/O correlations in the copy.

Copy display correlations Check this box to include display correlations in the copy.

Retain Address Check this box to retain the same addresses on the 

copied devices. A message appears if this is not possible. 

Retain Address can fail if the destination loop controller 

does not have sufficient free addresses. Retain Address 

always fails if the source and destination are the same 

loop.
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11.14 Paste Special - Display Items, Display Adders or Annunciators

This window appears in response to a Paste Special when pasting display items, display 

adders or entire annunciators.

Figure 92 Paste Special

The text summarizes what is being pasted and its destination, for example pasting three 

display items to frame 0.

A regular copy is defined as follows.

The LEDs and switches are copied using newly assigned LED Grps.

Common Control Status LEDS are an exception - all similar types share the same Grp., for 

example a copied and pasted Signal Silence would retain the LED Grp of the source.

All attributes (tags, flags) are replicated.

If I/O Correlations is checked, then these too are assigned to the new copy. This is a "deep" 

copy.

If I/O Correlations is not checked, then of course they are not copied. This is the "shallow" 

copy.

A Reference copy is defined as follows.

Table 39 Paste Special - Display Items, Display Adders or Annunciators

Name Description

Number of copies Enter the number of copies to make. The paste operation 

attempts to make the specified number of copies. If the 

capacity of the destination is exceeded a message 

appears saying how many copies were successfully 

made.

Make New Copy Choose this option to make an unrelated replica of the 

source.

Copy Correlations Check this box to copy the correlations from the source to 

the new items.

Make Reference Copy Choose this option to make a reference copy of the 

source.
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New LEDs and switches are defined, but they retain the LED Grp of the source.

If any 3 POSITION SLIDE SWITCH is encountered while attempting a "Reference Copy" of 

individual items, a complete adder or an entire annunciator, an error message is displayed and 

a roll back of the operation occurs.

Both the new copy and the source (and any subsequent reference copies) are marked with an 

asterisk to warn you that the items are 'linked" or cross referenced. A change to one (for 

example addition of correlations) affects the others.
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12.0 Correlations Pane

Programming a Fire Alarm Control Panel consists of correlating inputs to outputs. For 

example, you might correlate all the smoke detectors on the first floor to the speakers on the 

first and second floors, and smoke detectors on the second floor to the speakers on the first, 

second, and third floors, and so on.

Most of the primary lists (shown in the Details pane) are used in combination with correlations 

in the Correlations pane. The Correlation pane is a tabbed pane. Each tab shows a different 

category of circuit, display LED, and so on. See Figure 29.

12.1 Input Circuit Correlations

If the currently selected circuits are inputs then the correlation view has tabs for:

� Signals

� Relays

� Display Points (for example Input Zone and Bypass)

12.2 Output Circuit Correlations

If the currently selected circuits are outputs then the correlation view has tabs for:

� Alarm

� Supv

� Trouble

� Monitor

� Display Points (for example Output Zones and Bypass LEDs)

When you select Add Correlations, a window appears which displays the circuits and display 

items that can be correlated to the selected items in the top right pane.

Figure 93 Correlations window

The Correlations window mirrors the Correlations pane. If a tab is selected on one, the same 

tab is automatically selected on the other.

If multiple items are selected in the Details pane, then the Correlations Pane only shows those 

correlations that are common to all of them. This means that no correlations might be shown. 

If a mix of input and outputs are selected in the Details pane, then no correlations are shown.
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13.0 Differences Mode and Differences 
Report

13.1 Introduction

The Configurator can compare two jobs. The differences mode shows which elements have 

been added, removed or changed. The lists show in more detail which items have been 

modified or whether correlations have been added or removed.

In differences mode a report can be printed. The scope and depth of the print report can be 

chosen, similar to when printing a single job.

The differences report is intended primarily to provide the authorities with a detailed list of what 

has (and what has not) been changed. Such a report can used to justify only minor re-testing 

of an installation.

13.2 Primary and Secondary Job

The primary job is normally the older job, currently in service. It is the base against which the 

secondary job - the newer, modified job - is to be compared.

You normally first establish the primary job by opening it using the Job Menu and choosing the 

desired Job and Version. Then you invoke differences mode, where the secondary job is 

chosen.

This document occasionally refers to items that have been added or deleted. These terms are 

used with respect to the primary - assuming that the primary is the older job. There is nothing 

to prevent you from reversing this convention and establishing a newer job as the primary.

13.3 Initiating Differences Mode

Differences mode can be initiated either by selecting Compare Job Version from the Job 

Menu, or by clicking the Differences icon in the tool bar.

When you initiate Job Compare, the Job Compare Dialog is displayed.

Press OK to enter differences mode. This can take several minutes, as the program examines 

every component of each job and decides if it is added, removed or changed. Correlations are 

also compared during this phase. A changed correlation is reflected not only in the correlations 

list, but is propagated (as a modification) up to the device or circuit list and from there to the 

Device Loop in the job tree. A dialog is displayed to inform you of the progress of difference 

reporting and to allow the action to be canceled. If you cancel, the display reverts to the 

primary job, in normal mode.

13.3.1 Interpreting the results

When the comparisons have all been made, the jobs are presented as one job tree. See 

below.
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Figure 94 Differences

The magnifying glass icon represents an item that has been modified, symbolizing that it 

warrants a closer look: some lower level attributes have changed.

Items that have not changed have the green check mark icon, which means that there were no 

reportable changes on this item or any of its lower levels. If you chose a non-standard set of 

options and excluded, for example 'items that are modified', then a green check mark appears 

if there are modifications, but no deletions and additions. This is because you chose to ignore 

or exclude them. This icon is only used in the job tree. Items in lists are suppressed completely 

if you choose not to include items that are identical. If you include items that are identical, then 

they have no icon at all. This is to avoid clutter and aid readability of the lists.

Notice that the Main Display itself did not change. None of its attributes were changed. The 

fact that some changes were made to its Base Control/annun. does not cause the Main 

Display itself to be marked as changed.

An item that has been removed (is present on the primary job, but not present on the 

secondary) is depicted with this symbol.

And, conversely, items that have been added are identified with this symbol.

Where a minor modification to a form, a device, LED or switch has been made, two adjacent 

rows are presented. The attributes that remained the same are represented by ditto marks in 

the second row.

Where the only difference between two list items is in its correlations, the magnifying glass 

symbol is used. Again, this means that you can click on it to view the actual changes: in this 

case, the correlations in the bottom, right pane.
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14.0 Printing

The print and print preview operations function just as in regular mode. In addition to choosing 

how much of the job to print, you can also decide whether to print Outputs with Input 

Correlations, Inputs with Output Correlations or Display Correlations.

If you chose to suppress identical items when you entered differences mode, then any node in 

the tree that is marked with a green check mark is not printed. Items whose only difference is 

in the lower level correlations are also not printed: only the actual correlations. On the printout 

the symbols - - > and < - - are used in place of the added and removed icons. The same 

symbols are used on pairs of lines to indicate which one is from the primary ( < -- ) and 

secondary ( - - > ).

If the print range of the job was Complete Job, then you may decide to choose only one of 

Input or Output Correlations, since every input has a corresponding output somewhere on the 

job. Be aware that if the print range does not encompass the complete job, then selecting only 

Input or Output may not include all correlations.

The Input and Output summaries list any changes to the UDACT numbers to be reported to 

the authorities.

TIP: Print Preview works best if you maximize the Preview window (other windows can't cover 

part of it, requiring a redraw when moved) and zoom in/out so that a complete out put page fits 

in the window (you don't have to scroll to view other parts of a page, which would cause 

frequent redrawing).

When you initiate either Print or Print preview, the following dialog is displayed 

Figure 95 Print

Table 40 Print

Name Description

Print Range You can specify the range or scope of the print job using 

these controls.
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Complete Job Regardless of what item in the Job Tree you currently 

have selected, the complete job is printed. The print 

program prints all of the details of the Base Panel, 

followed by all of its loops, main display, etc. Then it goes 

to the next major node of the tree (e.g Loop Adder, CPU 

1), printing its details and all of its contained loops. This 

process continues in a depth first manner, until the entire 

job has been traversed and printed. Each node of the tree 

is started on a new page.

Current Node If you choose this option, the print job is restricted to 

details of the tree node or job component that you 

currently have selected in the Job Tree. No details of 

contained loops, etc. are printed.

Current Node and 

Subnodes

this option prints details of the currently selected tree node 

and all of its sub-items (and those items' sub-items, if 

any).

Outputs with Input Corrs If this box is checked, then the Inputs correlated to Output 

circuits are printed in addition to the regular print. This is 

done for any relevant tree nodes / loops that are included 

in the scope of the print job.

Inputs with Output Corrs If this check box is checked, then the Outputs correlated 

to Input circuits are printed. Status correlations are 

included with this option. This is done for any tree nodes / 

loops that are included in the scope of the print job.

Display Corrs If this check box is checked, then the Display correlations 

are printed. This is done for any relevant tree nodes / 

loops that are included in the scope of the print job.

General Note - Correlations If a tree node has no correlations, then it is skipped 

entirely by the print program. If a tree node has 

correlations, then a header is printed for every "correlated 

from" device. Beneath it, and tabbed, are all of the devices 

to it. If it has none, the major header is still printed.

Setup This button launches the standard Windows printer setup 

dialog. You may choose a printer other than the default, or 

select a different paper size. The print program is 

designed to fit all information on Letter sized paper (8 ½ 

by 11) in portrait orientation. You may also choose Legal 

sized paper (8 ½ by 14). The print program takes 

advantage of the longer paper and fit more devices on one 

page for lists and correlations. If you choose smaller paper 

the font will be scaled down accordingly (within practical 

limits).

Table 40 Print (Continued)

Name Description
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14.1 Print Setup

Launch the standard Windows Print Setup dialog to specify the printer, paper size and 

orientation.

Figure 96 Print Setup

Pages this check box is only available when performing a print. It 

is disabled for print preview.

During preparation of a print preview or a print, the 

program makes one first pass through the tree nodes and 

loops that are in scope. It does this to calculate the page 

count. However, the program cannot insert the Max Page 

Number into the dialog because it is not known at that 

time.

If you need to repeat part of a print job (e.g. because the 

printer jammed part way through a job), then you must 

note the start page and the end page - up to the maximum 

number of calculated pages - and enter them in the From 

and To fields.

Generally, you can more easily control which portions of a 

job you wish to have printed by selecting a node in the 

tree and printing only that node.

Table 40 Print (Continued)

Name Description
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